Eclipse: tiempo de inicio lento

Tengo Eclipse 3.6.1 en mi MacBook Air (2010) y los tiempos de inicio son lentos. Bueno, lento, comparado con mi Desktop, que es algo menos potente y tiene unos años).

El inicio generalmente toma 15 segundos, y de esto, 4 se gastan solo en la pantalla de presentación de Eclipse, antes de que Eclipse cargue algo. No hay proyectos abiertos al inicio.

Aquí hay una copia de mi eclipse.ini.

-startup
../../../plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
../../../plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.1.R36x_v20100810
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
512m
--launcher.defaultAction
openFile
-vmargs
-Xms256m
-Xmx512m
-Xdock:icon=../Resources/Eclipse.icns
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Dosgi.requiredJavaVersion=1.6
-Xverify:none
-XX:+UseConcMarkSweepGC
-XX:+CMSClassUnloadingEnabled
-XX:+CMSPermGenSweepingEnabled
-XX:+UnlockExperimentalVMOptions

-XX:+AggressiveOpts
-XX:+StringCache
-XX:+UseFastAccessorMethods
-XX:+UseLargePages
-XX:LargePageSizeInBytes=4m
-XX:AllocatePrefetchLines=1
-XX:AllocatePrefetchStyle=1
-Dide.gc=true

El problema no parece estar relacionado con los complementos: he desactivado los que no necesito y, independientemente de esta configuración o de si todos están seleccionados al inicio, solo se tarda 1 segundo en cargar los complementos.

Estoy ejecutando Eclipse 3.6.1 Cocoa x64 build (vainilla) con el complemento Zend Studio. La máquina tiene 4 GB de RAM, un SSD con más del 64% de espacio libre, 1.6 GHz (4 MB de caché L2). El sistema operativo es Mac OS X 10.6.6, la última versión de Java disponible, 1.6.

A modo de comparación, mi escritorio, un antiguo P4 3GHZ (512K L2 Cache) con una unidad de 7200RPM, menos del 40% de espacio libre, Eclipse (misma configuración) se carga en menos de 7 segundos, de manera consistente. Tenga en cuenta que esta es una máquina con Windows, con la última versión de Java instalada.

preguntado el 08 de enero de 11 a las 17:01

prueba este eclipse.ini: stackoverflow.com/questions/142357/… -

No, sin cambios: / Debe ser java lento :( -

1 Respuestas

Utiliza la versión de 64 bits. Pruebe con la versión de 32 bits.

Respondido el 08 de enero de 11 a las 22:01

Tarda unos 10 segundos en mi MacBook Pro con Eclipse JEE. ¿Es solo la fase de inicio o también cuando trabajas con él? Además, no estoy seguro de que Zend no requiera recursos adicionales. - Thorbjørn Ravn Andersen

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.