Qt Phonon no reproduce videos

Tengo una aplicación que muestra algunos mensajes y videos predefinidos usando el Phonon recursos del Qt Biblioteca. Siempre funcionó muy bien hasta hace poco, cuando el acceso a la máquina que ejecuta la aplicación debe realizarse a través de la red. Ahora, de más de 30 videos, solo uno se muestra correctamente.

Todos los videos se reproducen normalmente (el K-Lite paquete de códec está instalado) con Reproductor de Windows Media or Media Player Classic. Pero la aplicación no los reproduce.

¿Qué puedo hacer para solucionarlo?

preguntado el 11 de agosto de 11 a las 20:08

1 Respuestas

Phonon usa complementos del sistema para reproducir videos. Si tiene videos que usan, por ejemplo, el formato H.264, el complemento directshow predeterminado no puede reproducirlos. Hay complementos alternativos como vlc plugin y mplayer complemento disponible.

Tenga en cuenta que, aunque residen en el proyecto KDE, son complementos de Qt puros y simplemente alojados (y desarrollados) por KDE; son parte de hacer que Phonon funcione en Windows con KDE. No encontré ningún módulo precompilado (aunque la distribución de KDE debería tener algunos), pero compilarlos usted mismo debería ser relativamente fácil.

Respondido 12 ago 11, 00:08

Ese es el problema, antes de la actualización, simplemente funcionaba bien. Después de eso, simplemente dejó de funcionar. Línea K se instala como una forma de proporcionar más complementos de video. - Wanderson Silva

¿Qué backend de Phonon usas? - Smar

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.