Xcode ios SDK - dyld: símbolo no encontrado: _CFXMLNodeGetInfoPtr

I have a problem with xcode and ios development. Last year I decided to install xcode and ios sdks to learn how to build a ios app. All works fine.

Time past and I decided to format my mac to install a new MacOS on a brand new SSD.

Yesterday, I downloaded Xcode 4.2 with ios SDKs and installed it. I started a new projects then start it without editing nothing.

It failed with this error message :

CompileXIB exemple/en.lproj/FirstView.xib
cd /Users/karlcosse/iosDevs/exemple
setenv PATH "/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"
setenv XCODE_DEVELOPER_USR_PATH /Developer/usr/bin/..
/Developer/usr/bin/ibtool --errors --warnings --notices --output-format human-readable-text --compile /Users/karlcosse/Library/Developer/Xcode/DerivedData/exemple-fdgpmxhwzhcpnydzkgzelaqeaxnh/Build/Products/Debug-iphonesimulator/exemple.app/en.lproj/FirstView.nib /Users/karlcosse/iosDevs/exemple/exemple/en.lproj/FirstView.xib --sdk /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator4.3.sdk

dyld: Symbol not found: _CFXMLNodeGetInfoPtr
   Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security
Expected in: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator4.3.sdk/System/Library/Frameworks/CoreFoundation.framework/CoreFoundation
in /System/Library/Frameworks/Security.framework/Versions/A/Security
ibtoold(932,0x7fff712b6cc0) malloc: *** auto malloc[932]: error: auto_zone_set_associative_ref: object should point to a GC block or a global address, otherwise associations will leak. Break on auto_zone_association_error() to debug.

I browse the web but i didn't found any answers so... you are my last chance :D

(i'm currently downloading MacOS Lion to try if an upgrade will solved my problem... We'll see.

Thank you so much for your help !

preguntado el 28 de agosto de 11 a las 00:08

I don't think Lion will fix your problem… :) What are you doing in the app? Anything related to XML, web browsing? -

The real question is, what code did you add for that error to appear? -

I just started a new project and just click "run"... I didn't write one line of code ! -

I am seeing these logs in my console under iOS5/XCode 4 (just upgraded). I don't know if they affect the app though. -

1 Respuestas

I would use the latest stable version of Xcode available to me. If you're on Snow Leopard, Xcode 4.0.2. If you're on Lion, Xcode 4.1.

Xcode 4.2 is still in Developer Preview.

Respondido 28 ago 11, 18:08

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.