SBT 0.10 - eliminar la dependencia en Scala 2.8.1

Mi proyecto usa Scala 2.9, así que agregué

scalaVersion := "2.9.0-1"

a mi build.sbt archivar y ejecutar gen-idea. Sin embargo, IDEA todavía muestra Scala 2.8.1 (además de 2.9) en Bibliotecas externas. ¿Por qué y cómo eliminarlo?

preguntado el 28 de agosto de 11 a las 00:08

1 Respuestas

Su aplicación se compilará con la versión o versiones de Scala que elija. Sin embargo, SBT también es una aplicación de Scala y se compiló con Scala 2.8.1, por lo que it necesita las bibliotecas de Scala 2.8.1 para funcionar. Esto no tendrá ningún impacto en su aplicación.

Respondido 28 ago 11, 08:08

Lo más probable es que SBT cambie a 2.9.1 tan pronto como se publique. - soc

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.