¿Error de spork con el paquete ejecutivo?

Siempre que corro spork, Estoy teniendo el siguiente error:

You have already activated spork 0.9.0.rc8, but your Gemfile requires spork 0.8.5. Consider using bundle exec. (Gem::LoadError)

mi archivo de gemas:

group :development, :test do
    gem "rspec"
    gem "rspec-rails"
    gem "factory_girl_rails"
    gem 'spork' 
    gem 'webrat'
    gem 'awesome_print'

    gem 'vcr'
    gem 'fakeweb'
end

He corrido bundle update y gem update e incluso gem update --system pero sigo viendo este error. corriendo bundle exec spork funciona, pero quiero saber por qué spork no lo hace y cómo puedo solucionarlo.

preguntado el 28 de agosto de 11 a las 00:08

2 Respuestas

En su Gemfile puede especificar:

gem 'spork', :version => 0.8.5

También es posible que desee eliminar spork más nuevo:

gem uninstall spork -v=0.9.0.rc8

respondido 19 mar '12, 11:03

Tal vez su problema ya esté resuelto (supongo), pero enfrenté un problema similar en los últimos días y encontré el motivo de este error. Tiene que ver con el control de versiones de todas las gemas necesarias cuando se usa el paquete. Cuando solo "spork"se proporciona entonces RubyGems se activa y busca una versión adecuada. Pero esto omite la versión especificada de la Gemfile que usaría el empaquetador. Sólo cuando "bundle exec spork", el agrupador puede buscar la versión en el Gemfile. En tu caso "spork"apunta a una gema instalada con la versión '0.9.0', tiempo "bundle exec spork" usos '0.8.5'. Hay una marca disponible ("bundle exec --binstubs") que crea un "bin"carpeta (> = bundler 1.0) y coloca todos los ejecutables especificados por Gemfile en ella. En lugar de" bundle exec spork ", es válido escribir"bin/spork".

Busque "Gem Versioning and Bundler: Doing it Right" por Yehuda Katz, explica todo con más detalle y me ayudó mucho.

Respondido 30 Oct 12, 06:10

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.