wampp o xampp: ¿cómo actualizar a mysql 6?

I'm on windows xp pro, I've been told to use mysql2 gem in my ruby on rails app. mysql 2 gm wont work unless you have mysql 6 installed. wamp and xampp do not have mysql 6 included in their latest versions! so how to install mysql 6...I'm using xampp and I do not want to install mysql then apache then php then phpmyadmin, i want to use something that has the whole package like wamp or xampp so I'm wondering if you know how to upgrade to mysql 6

and one more thing, is mysql 6 widely supported? i want to try my app on some shared hosting so i don't want to install mysql2 para el desarrollo y mysql in production just because the hosting providers doesn't support mysql 6

Cuando corro rake db:create veo:

rake aborted! incorrect mysql client library version! this gem was compiled for 6.0.0 but the client library is 5.5.12

preguntado el 30 de enero de 12 a las 19:01

if you cannot answer the question, just tell me if mysql6 is widely supported or not, so that i wouldn't waste my time fixing the problem! -

What did you do to solve this? -

@Railsbeginner please read my answer below -

2 Respuestas

i have solved this error by downloading [the zipped version of mysql Connector/C 6.0.2 for 32 bit][4] and copying libmysql.dll desde mysql-connector-c-noinstall-6.0.2-win32-vs2005\lib

a C:\RailsInstaller\Ruby1.9.2\bin

Respondido 22 Feb 12, 00:02

great! just needed to add mysql connector's dll to railsinstaller - Said Kaldybaev

mysql 5.5.20 is the latest stable version...i use 5.5.0 and 5.1 and mysql2 works fine

Respondido el 31 de enero de 12 a las 02:01

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.