Mac App Store: cambio de los requisitos mínimos del sistema

When I submitted my app to the Mac App Store, it displays something like this to users:

enter image description here

and it won't allow anybody with an earlier version to download the app.

Veo que hay un LSMinimumSystemVersion key in my app's Info.plist que está configurado para ${MACOSX_DEPLOYMENT_TARGET}.

If I want to let users with an earlier version than 10.7 to use my app, can I then just change the Deployment target? Will my app then run on versions earlier than 10.7 (I will be building the app on 10.7)?

Another question, can I make the change without having to wait for Apple to approve the binary again (I just want to change the minimum Mac OS X required version, not anything in the binary itself)?

preguntado el 01 de febrero de 12 a las 04:02

You might want to find a way to test on 10.6 before releasing. Hopefully it should be straightforward, but there are plenty of changes that could cause bugs on an earlier OS. -

1 Respuestas

Provided your binary supports it of course you can at least set the minimum system requirement to 10.6.6 (when the MAS came out) - and probably 10.6 if you wish.

There is no explicit rule that I know disallowing, say 10.5, but there is one forbidding "deprecated technologies" and this lists Rosetta which would undoubtedly be interpreted as no PowerPC binaries.

It's a change to your binary, it will have to be approved. Put a note in the comments to reviewers section stating that is all you've changed, can't hurt, may help.

Respondido 01 Feb 12, 20:02

Thanks, I have just resubmitted the app. I'll try to find a 10.6 system to test it on just in case. - houbysoft

@houbysoft: Track down a copy of VMWare Fusion 4.1 (not 4.1.1) and make yourself a 10.6 VM... - CRD

exactly what I thought about doing. Thanks :) - houbysoft

what's the reason for it having to be 4.1 btw? - houbysoft

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.