Dispositivo Adb sin conexión en Ubuntu Natty

I am developing on Android and I am running Ubuntu. I have a really hard time getting the device 'Online'. I already tried:

  • All the udev rules that can be found on the internet.
  • Add the .ini file in the .android folder.
  • The usual reboot computer, deivce, unplug device, uncheck developer and recheck it ...

At the moment I just spent about 30minutes to one houre just changing USB ports, rebooting the computer, device. And after a while it always works. But this is getting really frustrating spending so much time just to get the device recognized.

Something I noticed. When I spam adb devices while booting the tablet:

student@terminal32:~$ ./adb devices
List of devices attached 
46411960A012FCCE    device

student@terminal32:~$ ./adb devices
List of devices attached 
46411960A012FCCE    device

student@terminal32:~$ ./adb devices
List of devices attached 

student@terminal32:~$ ./adb devices
List of devices attached 

student@terminal32:~$ ./adb devices
List of devices attached 
????????????    offline

student@terminal32:~$ ./adb devices
List of devices attached 
????????????    offline

At first it recognized my devices, but then when it is fully booted, it apears to be offline anyway.

Can any one give me some tips on what I can do to fix this frustrating problem. And maybe someone can give me some inside on what the problem actually is, why does it still work after 30 minutes to one hour ?

preguntado el 03 de mayo de 12 a las 08:05

2 Respuestas

I just went through the same hell, reboot device, pc... various times actually.

Not saying that this would always work, but my last successful attempt at least did not involve unplugging or rebooting the pc: - adb client was running - device recognized but offline - device connected via usb

Then I simply rebooted the device (i.e. without unplugging or restarting the dab or anything).

Respondido el 10 de junio de 12 a las 00:06

Maybe a late comment, but I ended up never been able to fix the problem. Sometimes it worked instantly; somtimes I have spend more then an houre rebooting both devices unplugging everything. Good thing that once it worked it kept working as long as I did not unplug the device, so I only had to do this once every few days :) - Ingenuo

It happend to me recently, change your phone usb connection to PTP camera.

Respondido 26 Feb 14, 14:02

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.