Selenium Server en CentOS 6.2 no tiene entrada de teclado durante la prueba

We currently have a problem with SeleniumServer which is troubling me for 2 days, now...hope you can help me.

The Selenium Server is running on a 6.2 CentOS, Selenium Server is 2.21 y Firefox is 10.0.4.

When a test is starting up, SeleniumServer pone en marcha Firefox but he can not type anything in the form fields or press "Enter" to submit.

Even better, no one (not even me with VNC-Server) can write something in the form field, url bar, menus, press a key like "Enter", etc....it is as the keyboard is not present... It´s like Firefox is locked somehow.

If a start Firefox con Interactive-Mode : selenium-server.jar -interactive & cmd=getNewBrowserSession&1=*firefox&2=http://www.google.com everything is working fine, I can do all the tests manually.

I can also start firefox manually with just typing firefox in the shell and that is working fine, too.

So what is going on in Selenio y como Selenio comienza Firefox? Why is no Keyboard-Input available when running a Selenium-Test con SeleniumServer? We tested with MacOS y Windows, too and both working fine with the same test.

Cualquier idea sera apreciada.

Greetings from Berlin

preguntado el 03 de mayo de 12 a las 15:05

serverfault.com question -

1 Respuestas

Fixed it myself with an older version of Firefox. Firefox 7 worked for me.

contestado el 08 de mayo de 12 a las 16:05

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.