La etiqueta de salida de PHP no funciona

Instalé un nuevo WAMP en mi computadora (antes de usar XAMPP, todo estaba bien como recuerdo). Mi problema es la etiqueta de salida de php (<?= ?>) que no funciona (en el navegador, cuando hago clic en mostrar código fuente, aparece exactamente en el archivo, por lo que no se procesa...)

¿Me equivoco en algo? ¿Hay alguna opción en php.ini para activar esta etiqueta? Necesito esta etiqueta.

Codifique cómo lo intenté:

<?php
 $examples = "Some text...";
?>
<!DOCTYPE html>
<html>
    <head>
        <title>Examples</title>
    </head>
    <body>
        <h1>Examples</h1>
        <ul>
            <?= $examples ?>
        </ul>
    </body>
</html>

preguntado el 03 de mayo de 12 a las 15:05

2 Respuestas

Puede activarlo para actualizar php.ini para permitir etiquetas cortas. Pase el mouse sobre la opción de menú PHP en WAMP y busque la configuración. Colocar short_open_tag a on.

contestado el 03 de mayo de 12 a las 15:05

Aparte, a partir de PHP 5.4 <?= ?> la sintaxis está disponible independientemente de short_open_tag estar encendido o apagado. - Wiseguy

Gracias por el nombre de ajuste exacto. Estaba haciendo esto de memoria y no podía recordar el nombre exacto de la configuración. - John Conde

Puede actualizar su php.ini. Pero creo que es mejor usar las etiquetas clásicas para evitar problemas con la etiqueta xml

contestado el 03 de mayo de 12 a las 15:05

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.