Error al compilar el marco spring3 con gradle

Traté de construir el marco Spring 3 usando gradle, en ubuntu 12.04. pero hubo un error cuando los aspectos de construcción progresan. el error es el siguiente:

spring-aspects:compileJava
Download http://repo.springsource.org/libs-release/org/aspectj/aspectjtools/1.6.12/aspectjtools-1.6.12.jar
[ant:iajc] <Unknown> [warning] Found @DeclareAnnotation while current release does not support it (see 'org.aspectj.weaver.bcel.AtAjAttributes')
[ant:iajc]  
:spring-aspects:classes
:spring-aspects:jar
:spring-expression:javadoc
/home/hendri/spring-framework/spring-expression/src/main/java/org/springframework/expression/spel/ast/OpMultiply.java:28: error: unmappable character for encoding UTF8
 * <p>If any of the operands is of a reference type, unboxing conversion (�5.1.8) is performed. Then:<br>
                                                                          ^
1 error

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':spring-expression:javadoc'.
> Javadoc generation failed.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 24 mins 10.5 secs

¿Alguien puede ayudarme a pasar este error y construir el marco Spring 3? Gracias..

preguntado el 12 de junio de 12 a las 08:06

1 Respuestas

Intenta actualizar el código Spring. Si eso no funciona, mire contra qué codificación está compilando.

Respondido el 12 de junio de 12 a las 09:06

eso no funciona, pero traté de volver a descargarlo desde svn e intenté construir uno nuevo, y funcionó... no sé por qué, pero funciona :D gracias por tu ayuda :D/ - Hendri

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.