HTTP Error 500.19 - Error interno del servidor

Tengo este problema después de implementar mi paquete web en IIS:

Error HTTP 500.19 - Error interno del servidor No se puede acceder a la página solicitada porque los datos de configuración relacionados para la página no son válidos.

Esta sección de configuración no se puede utilizar en esta ruta. Esto sucede cuando la sección está bloqueada en un nivel principal. El bloqueo es predeterminado (overrideModeDefault="Deny") o se establece explícitamente mediante una etiqueta de ubicación con overrideMode="Deny" o el legado allowOverride="false".

Config Source:


119:     </modules>
120:     <handlers>
121:       <remove name="WebServiceHandlerFactory-Integrated" />

¿Cómo puedo solucionar este problema?

preguntado el 12 de junio de 12 a las 16:06

Eche un vistazo a mi respuesta en stackoverflow.com/questions/5091640/…. Espero que esto ayude... -

3 Respuestas

Ver escenario 7 en esta página Solución de problemas de errores HTTP 500.19 en IIS 7, se ve bastante idéntico a su mensaje de error.

Uno de los puntos clave creo que es el siguiente:

Esto generalmente indica que ASP.NET no está instalado o tiene una instalación dañada o incompleta porque la instalación de asp.net desbloquea esa sección. Por lo tanto, si este es el caso, se debe instalar la característica asp.net desde el Administrador del servidor (en Función del servidor web en Windows Server 2008 y en Características del programa-> Servidor de aplicaciones en Vista/Windows7). Este KB929772 habla sobre el motivo del error de instalación de ASP.NET.

Si solo está haciendo esto en su IIS de escritorio local en lugar de en un servidor, es posible que necesite usar aspnet_regiis para volver a registrar .NET con IIS, aunque no garantizo que funcionará para desbloquear la sección.

Respondido el 12 de junio de 12 a las 16:06

Acabo de experimentar:

HTTP Error 500.19 - Error interno del servidor

Y el problema era (holy moly):

  • En mi IIS de desarrollo local, agregué un nuevo tipo MIME para mi sitio.
  • El nuevo tipo MIME se agregó automáticamente a mi web.config (en sistema.webServer sección). no me di cuenta de eso.
  • Cuando publiqué la aplicación en el servidor de producción, todo (cargar scripts/css/images/etc.) dejó de funcionar. (Error interno de servidor 500.19)
  • Después de profundizar más en el problema, finalmente vi el mensaje de excepción: Tipo MIME duplicado

Respondido 19 Oct 12, 12:10

Recibí este error. Busqué en Google durante horas. Probé todo tipo de sugerencias. Después de horas de frustración, resultó que solo tenía una comilla doble extra en mi archivo cshtml. Eliminé la cotización y todo volvió a funcionar. Entonces el error es engañoso. Publico esto en caso de que alguien más se encuentre con el mismo problema.

Respondido 06 Abr '20, 22:04

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.