Modo WSDL que causa fallas de segmentación

Tengo Ubuntu 10.04 LTS, que usa PHP 5.3.2. Estoy tratando de hacer que WSO2 para PHP 2.1.0 funcione, y estoy seguro de que he instalado todos los paquetes necesarios. La compilación y la instalación fueron exitosas y he repasado las instrucciones de instalación varias veces para confirmar que no me he saltado ningún paso.

Casi todas las secuencias de comandos de muestra proporcionadas funcionan perfectamente.

Sin embargo, dos de las muestras (Cliente en modo WSDL que usa WSDL 1.1 y Cliente en modo WSDL que usa WSDL 2.0) están produciendo fallas de segmentación. Tan pronto como se ejecuta cualquiera de estos dos ejemplos, esto aparece en mi registro de errores de Apache2:

[Tue Jun 12 07:44:18 2012] [notice] child pid 18246 exit signal Segmentation fault (11)

Parece que el modo WSDL está roto de alguna manera.

Tengo las siguientes directivas en mi php.ini:

extension = "wsf.so"
wsf.home = "/usr/lib/php5/20090626/wsf_c"
wsf.log_path = "/var/log"
wsf.log_level = 4

¿Alguien puede proporcionar alguna idea de lo que podría estar yendo mal?

preguntado el 12 de junio de 12 a las 18:06

Acabo de instalar Ubuntu 12.04 LTS (64 bits) en una máquina virtual y configuré WSO2 para PHP 2.1.0 en ella. Todo se compiló a la perfección, pero sigo teniendo fallas de segmentación en las muestras de WSDL. -

Otro seguimiento... Instalé una pila WAMP en mi PC con Windows 7 y pasé por la instalación del binario de Windows WSO2 para PHP 2.1.0. El ejemplo de WSDL funciona bien. ¿Hay una incompatibilidad de Linux aquí? -

1 Respuestas

¿Puede verificar qué versión de SSL está usando en WAMP en comparación con Ubutnu? Encontré este problema que podría ser una pista: https://wso2.org/jira/browse/WSFPHP-467

Respondido 23 Jul 12, 02:07

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.