Creación de aplicaciones de mapas de muestra monodroid

Estoy usando la última descarga de la aplicación de ejemplo de mapas 'MapsAndLoactionDemo' de Xamarin y en Visual Studio 2010 obtengo los siguientes errores de compilación:

Error   10
Activate(java.lang.String,java.lang.String,java.lang.Object,java.lang.Object[]) in mono.android.TypeManager cannot be applied to (java.lang.String,java.lang.String,mapsandlocationdemo.MapWithOverlayActivity,java.lang.Object[])

mono.android.TypeManager.Activate ("MapsAndLocationDemo.MapWithOverlayActivity, MapsAndLocationDemo, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", "", this, new java.lang.Object[] {  });
    D:\Projects\Android\MapsAndLocationDemo\MapsAndLocationDemo\obj\Debug\android\src\mapsandlocationdemo\MapWithOverlayActivity.java   25  28  MapsAndLocationDemo

¿Qué está mal?

preguntado el 02 de julio de 12 a las 14:07

¡Agregar la línea donde realmente ocurre el error de compilación podría ayudar! -

1 Respuestas

Necesitas instalar la API de Google en su emulador
Puedes seguir esto: http://developer.xamarin.com/samples/MapsDemo/

Instalación del complemento SDK de Android de las API de Google
Las API de Google requieren la biblioteca de complementos "API de Google", que se proporciona para cada nivel de API. Debe descargarlo para el nivel de API al que desea apuntar.

Para instalar el complemento SDK de Android de las API de Google:

  1. Inicie el administrador SDK de Android: $ANDROID_SDK_PATH/tools/android
  2. Dentro del administrador SDK de Android, haga clic en Paquetes disponibles en el panel de la izquierda.
  3. En el panel de la derecha, vaya al nodo de vista de árbol Complementos de terceros/Complementos de Google Inc. (dl-ssl.google.com)
  4. Seleccione la casilla de verificación para, por ejemplo, "API de Google de Google Inc., API de Android 8, revisión 2".
  5. Haga clic en el botón Instalar seleccionado en la esquina inferior derecha.
  6. En el cuadro de diálogo "Elegir paquetes para instalar", seleccione el botón de opción Aceptar y luego haga clic en el botón Instalar.

Si estás usando Emulador Genymotion Error INSTALL_FAILED_MISSING_SHARED_LIBRARY en Android

contestado el 23 de mayo de 17 a las 12:05

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.