¿Cómo crear una clase de dominio automáticamente en Groovy?

Alguien sabe cómo crear un clase de dominio automáticamente en groovy?

Aquí está mi BuildConfig.groovy:

grails.project.class.dir = "target/classes"
grails.project.test.class.dir = "target/test-classes"
grails.project.test.reports.dir = "target/test-reports"
grails.project.target.level = 1.6
//grails.project.war.file = "target/${appName}-${appVersion}.war"

grails.project.dependency.resolution = {
    // inherit Grails' default dependencies
    inherits("global") {
        // uncomment to disable ehcache
        // excludes 'ehcache'
    }
    log "warn"
 // log level of Ivy resolver, either 'error', 'warn', 'info', 'debug' or 'verbose'
    repositories {
        grailsCentral()
        // uncomment the below to enable remote dependency resolution
        // from public Maven repositories
        mavenCentral()
        //mavenLocal()
        //mavenRepo "http://snapshots.repository.codehaus.org"
        //mavenRepo "http://repository.codehaus.org"
        //mavenRepo "http://download.java.net/maven/2/"
        //mavenRepo "http://repository.jboss.com/maven2/"
    ebr()
    }
    dependencies {
        // specify dependencies here under either 'build', 'compile', 'runtime', 'test' or 'provided' scopes eg.
grails.project.dependency.resolution = { plugins{compile ":svn:1.0.2" } }
        // runtime 'mysql:mysql-connector-java:5.1.5'
    }

    plugins {
        build(":tomcat:$grailsVersion",
              ":release:1.0.0") {
            export = false
        }
    }
}

preguntado el 04 de julio de 12 a las 08:07

¿Qué quiere decir "automáticamente"? -

1 Respuestas

Si te refieres a crear automáticamente un dominio maravilloso a partir de la tabla de la base de datos, puedes probar con el Complemento inverso de base de datos

Respondido 04 Jul 12, 08:07

Se produjo el siguiente error cuando intento instalar Complemento inverso de base de datos - jishin

::::::::::::::::::::::::::::::::::::::::::: :: DEPENDENCIAS NO RESUELTAS :: :::::::::::::::::::::::::::::::::::::::::::: :: org.grails.plugins#svn;1.0.0.M1: no encontrado :::::::::::::::::::::::::::::::::: :::::::::::: | Error No se pudo resolver las dependencias (establezca el nivel de registro en 'advertir' en BuildConfig.groovy para obtener más información): - org.grails.plugins#svn;1.0.0.M1: no encontrado - jishin

Agregue estas dependencias en su BuildConfig.groovy grails.project.dependency.solution = { plugins{ compile ":svn:1.0.2" } } - Fabiano Taioli

De nuevo el mismo error... dependencias { grails.project.dependency.solution = { plugins{compile ":svn:1.0.2" } } } ¿algún error en este código de dependencia? - jishin

intente ejecutar "grails refresh-dependencies" y luego "grails dependency-report" y vea en el informe si svb 1.0.0.M1 todavía está activado y por quién: Fabiano Taioli

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.