¿Cómo habilitar el soporte de hardware para libEGL para Tegra 2 Linux?

Estoy tratando de ejecutar mi aplicación OpenGL ES Ubuntu 11.04 instalada en la placa de desarrollo Harmony (Tegra 2); sin embargo, cuando uso paquetes:

libegl1-mesa, libegl1-mesa-dev, libegl1-mesa-drivers
libgles2-mesa, libgles2-mesa-dev

informes de aplicación:

libEGL warning using software fallback

Recibí el mismo mensaje cuando intenté iniciar el ejemplo provisto en el paquete mesa-utils-extra llamado /usr/bin/es2gears pero después de actualizar los controladores:

export LDK_ROOTFS_DIR=/
cd Linux_for_Tegra
./apply_binaries.sh

y crear enlaces simbólicos como en la "Guía de desarrolladores del paquete de controladores Tegra Linux"

mv /usr/lib/libEGL.so /usr/lib/libEGL.so.1
mv /usr/lib/libGLESv2.so /usr/lib/libGLESv2.so.2
ln -s /usr/lib/libEGL.so.1 /usr/lib/libEGL.so
ln -s /usr/lib/libGLESv2.so.2 /usr/lib/libGLESv2.so

Puedo iniciar es2gears usando aceleración de hardware (2 veces más rápido).

Mi pregunta es ¿dónde puedo obtener paquetes de desarrollo que usen las bibliotecas libEGL.so y libGLESv2.so apropiadas para poder compilar mi aplicación?

preguntado el 04 de julio de 12 a las 09:07

1 Respuestas

contestado el 13 de mayo de 13 a las 10:05

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.