Paquetes faltantes en el marco osgi

Estoy tratando de ejecutar el paquete de dígrafos de región de Equinox en Eclipse IDE. Cuando ejecuto el paquete relevante usando el comando de inicio en el símbolo del sistema OSGi, aparece un error que dice No se pudo resolver el paquete. Razón: Restricción faltante: Paquete de importación: org.osgi.framework.hooks.bundle; versión="1.0.0". Para averiguar la versión existente en el marco, probé el comando p org.osgi.framework.hooks.bundle. El resultado muestra todos los paquetes en el marco. en esa lista org.osgi.framework.hooks.bundle No está ahí. Este es el mismo caso para algunos otros paquetes como org.osgi.framework.hooks.resolver. ¿Alguna ayuda sobre cómo solucionar este problema?

preguntado el 04 de julio de 12 a las 10:07

1 Respuestas

¿Qué versión de Eclipse estás usando?

La org.osgi.framework.hooks.bundle El paquete se agregó en OSGi Release 4.3, por lo que necesitaría una versión de Eclipse que lo admita, que sería al menos Eclipse 3.7 (Indigo).

Respondido 04 Jul 12, 11:07

Hola, muchas gracias por la respuesta, después de usar Indigo y actualizar la versión del marco OSGi, funciona bien. - Harish

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.