servidor de rieles en modo de depuración

Cuando trato de ejecutar el servidor de rieles en modo depurador usando "servidor de rieles --depurador". Recibo el siguiente error en mi consola.

/home/navyug/.rvm/gems/ruby-1.9.3-p194@global/gems/rake-0.9.2.2/lib/rake/ext/module.rb:36:in `const_missing': uninitialized constant Debugger::LocalInterface::Readline (NameError)
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/ruby-debug19-0.11.6/cli/ruby-debug/interface.rb:55:in `block (2 levels) in initialize'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/ruby-debug19-0.11.6/cli/ruby-debug/interface.rb:53:in `each'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/ruby-debug19-0.11.6/cli/ruby-debug/interface.rb:53:in `block in initialize'
    from /home/navyug/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/open-uri.rb:35:in `open'
    from /home/navyug/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/open-uri.rb:35:in `open'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/ruby-debug19-0.11.6/cli/ruby-debug/interface.rb:52:in `initialize'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/ruby-debug19-0.11.6/cli/ruby-debug/processor.rb:61:in `new'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/ruby-debug19-0.11.6/cli/ruby-debug/processor.rb:61:in `initialize'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/ruby-debug19-0.11.6/cli/ruby-debug.rb:9:in `new'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/ruby-debug19-0.11.6/cli/ruby-debug.rb:9:in `<module:Debugger>'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/ruby-debug19-0.11.6/cli/ruby-debug.rb:8:in `<top (required)>'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.7/lib/rails/rack/debugger.rb:9:in `initialize'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/rack-1.4.1/lib/rack/server.rb:295:in `new'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/rack-1.4.1/lib/rack/server.rb:295:in `block in build_app'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/rack-1.4.1/lib/rack/server.rb:291:in `reverse_each'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/rack-1.4.1/lib/rack/server.rb:291:in `build_app'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/rack-1.4.1/lib/rack/server.rb:301:in `wrapped_app'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/rack-1.4.1/lib/rack/server.rb:252:in `start'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.7/lib/rails/commands/server.rb:70:in `start'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.7/lib/rails/commands.rb:55:in `block in <top (required)>'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.7/lib/rails/commands.rb:50:in `tap'
    from /home/navyug/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.7/lib/rails/commands.rb:50:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'

Entorno RubyGems

  • VERSIÓN RUBYGEMS: 1.8.24
  • VERSIÓN RUBY: 1.9.3 (nivel de parche 2012 del 04-20-194) [i686-linux]
  • DIRECTORIO DE INSTALACIÓN: /home/navyug/.rvm/gems/ruby-1.9.3-p194
  • EJECUTABLE DE RUBÍ: /home/navyug/.rvm/rubies/ruby-1.9.3-p194/bin/ruby
  • DIRECTORIO EJECUTABLE: /home/navyug/.rvm/gems/ruby-1.9.3-p194/bin
  • PLATAFORMAS RUBYGEMS:
    • rubí
    • x86-linux
  • CAMINOS DE GEM:
    • /home/navyug/.rvm/gems/ruby-1.9.3-p194
    • /home/navyug/.rvm/gems/ruby-1.9.3-p194@global
  • CONFIGURACIÓN DE GEM:
    • : update_sources => verdadero
    • : verbose => verdadero
    • : benchmark => falso
    • : backtrace => falso
    • : bulk_threshold => 1000
  • FUENTES REMOTAS:

preguntado el 27 de julio de 12 a las 06:07

1 Respuestas

Creo que falta el paquete Readline en su configuración. Como está utilizando RVM, intente instalar el paquete readline a través de rvm. Estos enlaces pueden ser útiles:

contestado el 23 de mayo de 17 a las 13:05

Para OSX, esta es una excelente guía: github.com/guard/guard/wiki/… - Bret Weinraub

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.