tinyMCE - tinymce-rails - problemas de precompilación de activos

Estoy realmente perplejo sobre cómo implementar tinyMCE. La precompilación falla y obtengo el mensaje Lo sentimos, pero algo salió mal. - error.

Intenté usar la gema tinymce-rails pero simplemente no pude hacer que funcionara incluso en desarrollo siguiendo exactamente todas las instrucciones en la página de github. Ojalá hubiera un manual un poco detallado. En particular, no pude hacer que los parciales con el código del creador de formularios funcionaran con él.

Creo que si simplemente copio el código js original de tinyMCE en public/javascripts/tinyMCE y hago que enginx sirva los archivos estáticos, debería funcionar, pero todavía lo necesito en desarrollo y no pude hacer que Rails funcione con él de esa manera. Aún así, el obstáculo es el error de precompilación de capistrano que causa el error anterior.

Incluso probé tinymce-hammer pero tampoco pude hacerlo funcionar. ¿Hay un solo archivo, editor de texto enriquecido simple?

Tengo que hacer esto hoy y por eso estoy luchando.

Daría la bienvenida a cualquier solución... pero incluya la mayor cantidad de detalles o direcciones URL. Gracias un montón.

preguntado el 31 de julio de 12 a las 14:07

0 Respuestas

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.