Visual Studio 2010 usa incorrectamente la ruta Windows SDK v8.0A

Recientemente desinstalé la vista previa para desarrolladores de Visual Studio 2013 (creo) y ahora Visual Studio 2010 comenzó a darme el siguiente error:

Error 1 La tarea no pudo encontrar "sgen.exe" usando SdkToolsPath "" o la clave de registro "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v8.0A". Asegúrese de que SdkToolsPath esté configurado y que la herramienta exista en la ubicación específica del procesador correcta en SdkToolsPath y que Microsoft Windows SDK esté instalado C:\tfs_views\Platform\Main\AMC2000\DotNet\Configuration\ConfigModel\ConfigModel\ConfigModel\ConfigModel. csproj 111 5 Modelo de configuración (Modelo de configuración\Modelo de configuración)

Debido a un paso de compilación personalizado (descrito aquí)

He encontrado esta pregunta que describió un error similar. En este caso, la resolución es instalar Windows SDK v7.1 en la máquina de compilación; sin embargo, ya tengo instalada la versión correcta del SDK (v7.1), Visual Studio elige usar la versión incorrecta (v8.0A) .

¿Cómo puedo arreglar Visual Studio para usar el SDK correcto nuevamente?

preguntado el 31 de julio de 12 a las 15:07

2 Respuestas

Logré solucionar esto reinstalando Visual Studio 2010 (aunque esto tomó bastante tiempo)

Respondido 15 ago 12, 15:08

El usado Platform Toolset debemos influir en esto: Lo encuentras en el General sección de las propiedades del proyecto:

enter image description here

respondido 07 nov., 17:10

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.