Errores de SSL con QtWebkit en sitios https en Ubuntu

Estoy creando una aplicación de navegador basada en qtwebkit en Ubuntu 12.04 LTS. Cuando lo uso para acceder a sitios web https, tengo muchos errores de SSL. Por ejemplo, cuando entro a www.paypal.com, me sale este mensaje:

Errores SSL para: https://t.paypal.com/ts?v=0.1&t=1341683749338&g=420&e=im&pgrp=main%3Amktg%3Apersonal%3A%3Ahome&page=main%3Amktg%3Apersonal%3A%3Ahome%3A%3A%3ANotInTest%3B

No se pudo encontrar el certificado del emisor de un certificado buscado localmente. El certificado de CA raíz no es de confianza para este propósito. No se pudieron verificar los certificados.

Estoy usando QtSDK 4.8.1. La aplicación está vinculada a libssl 0.9.8. Aunque ubuntu viene con libssl 1.0, la versión precompilada de QtSDK 4.8.1 está vinculada a 0.9.8. Así que tengo que instalar libssl 0.9.8 para que funcione.

La misma aplicación funciona bien en Windows y Mac.

Si alguien sabe cómo resolver este problema, por favor comparta conmigo. ¡Muchas gracias!

preguntado el 24 de agosto de 12 a las 07:08

1 Respuestas

Aquí hay un enlace a otra pregunta de StackOverflow que creo que tiene la solución a sus problemas: ¿Es esta la forma correcta de configurar el protocolo SSL con QWebPage?

Además, este hilo: http://qt-project.org/forums/viewthread/19690 en los foros qt habla exactamente de los mismos problemas que ha estado experimentando.

contestado el 23 de mayo de 17 a las 13:05

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.