Error al instalar Watir en Windows 8

Hi I'm trying to install watir. I've installed Ruby and updated the RubyGem manager. When I try and install watir (Windows 8 64bit) I get the following:

C:\devkit>gem install watir
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
ERROR:  Error installing watir:
        ERROR: Failed to build gem native extension.

    C:/Ruby200-x64/bin/ruby.exe extconf.rb
checking for ffi.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=C:/Ruby200-x64/bin/ruby
        --with-ffi_c-dir
        --without-ffi_c-dir
        --with-ffi_c-include
        --without-ffi_c-include=${ffi_c-dir}/include
        --with-ffi_c-lib
        --without-ffi_c-lib=${ffi_c-dir}/
        --with-libffi-config
        --without-libffi-config
        --with-pkg-config
        --without-pkg-config
C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:431:in `try_do': The compiler failed to generate an executable
 file. (RuntimeError)
You have to install development tools first.
        from C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:562:in `try_cpp'
        from C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:1041:in `block in have_header'
        from C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:892:in `block in checking_for'
        from C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:337:in `block (2 levels) in postpone'
        from C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:307:in `open'
        from C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:337:in `block in postpone'
        from C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:307:in `open'
        from C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:333:in `postpone'
        from C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:891:in `checking_for'
        from C:/Ruby200-x64/lib/ruby/2.0.0/mkmf.rb:1040:in `have_header'
        from extconf.rb:16:in `<main>'


Gem files will remain installed in C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/ffi-1.8.1 for inspection.

Results logged to C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/ffi-1.8.1/ext/ffi_c/gem_make.out

preguntado el 23 de abril de 13 a las 13:04

1 Respuestas

Do you hav the correct version of devkit? Looks like you need Ruby 2.0.0 x64 (64bits): mingw64-64-4.7.2 de http://rubyinstaller.org/downloads/

Respondido 23 Abr '13, 14:04

Also check your Windows PATHS are pointing to the correct versions. Use absolute paths to be extra sure. - Tienda

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.