Código de error Heroku H10

I've been trying succesfully deploy my app! Went on my site and it says the annoying old application error, so i checked my logs and this is what I see

2013-05-05T10:42:16.387820+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands.rb:50:in `<top (required)>'
2013-05-05T10:42:16.387760+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands.rb:50:in `tap'
2013-05-05T10:42:16.387103+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:in `initialize'
2013-05-05T10:42:16.387411+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:200:in `app'
2013-05-05T10:42:16.387878+00:00 app[web.1]:    from script/rails:6:in `require'
2013-05-05T10:42:16.387955+00:00 app[web.1]:    from script/rails:6:in `<main>'
2013-05-05T10:42:16.387701+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands.rb:55:in `block in <top (required)>'
2013-05-05T10:42:16.387353+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:40:in `parse_file'
2013-05-05T10:52:32.322631+00:00 heroku[web.1]: State changed from crashed to starting
2013-05-05T10:52:33.807655+00:00 heroku[web.1]: Starting process with command `bundle exec rails server -p 25083`
2013-05-05T10:52:38.866563+00:00 app[web.1]: DEPRECATION WARNING: You have Rails 2.3-style plugins in vendor/plugins! Support for these plugins will be removed in Rails 4.0. Move them out and bundle them in your Gemfile, or fold them in to your app as lib/myplugin/* and config/initializers/myplugin.rb. See the release notes for more on this: http://weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-has-been-released. (called from <top (required)> at /app/config/environment.rb:5)
2013-05-05T10:52:38.867009+00:00 app[web.1]: DEPRECATION WARNING: You have Rails 2.3-style plugins in vendor/plugins! Support for these plugins will be removed in Rails 4.0. Move them out and bundle them in your Gemfile, or fold them in to your app as lib/myplugin/* and config/initializers/myplugin.rb. See the release notes for more on this: http://weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-has-been-released. (called from <top (required)> at /app/config/environment.rb:5)
2013-05-05T10:52:41.559472+00:00 app[web.1]: => Call with -d to detach
2013-05-05T10:52:41.559472+00:00 app[web.1]: /app/app/models/follow.rb:3:in `<class:Follow>': uninitialized constant Follow::ActsAsFollower (NameError)
2013-05-05T10:52:41.559472+00:00 app[web.1]:    from /app/app/models/follow.rb:1:in `<top (required)>'
2013-05-05T10:52:41.559812+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/engine.rb:436:in `eager_load!'
2013-05-05T10:52:41.559812+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/application/finisher.rb:53:in `block in <module:Finisher>'
2013-05-05T10:52:41.559812+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/engine.rb:436:in `each'
2013-05-05T10:52:41.559812+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/initializable.rb:30:in `instance_exec'
2013-05-05T10:52:41.559812+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/initializable.rb:55:in `block in run_initializers'
2013-05-05T10:52:41.559812+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/initializable.rb:54:in `each'
2013-05-05T10:52:41.559472+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/engine.rb:438:in `block in eager_load!'
2013-05-05T10:52:41.559472+00:00 app[web.1]: => Ctrl-C to shutdown server
2013-05-05T10:52:41.559472+00:00 app[web.1]: Exiting
2013-05-05T10:52:41.559472+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/engine.rb:438:in `each'
2013-05-05T10:52:41.559472+00:00 app[web.1]: => Rails 3.2.12 application starting in production on `http://0.0.0.0:25083`
2013-05-05T10:52:41.559472+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/engine.rb:439:in `block (2 levels) in eager_load!'
2013-05-05T10:52:41.559472+00:00 app[web.1]: => Booting WEBrick
2013-05-05T10:52:41.559812+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/initializable.rb:30:in `run'
2013-05-05T10:52:41.560273+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands.rb:50:in `tap'
2013-05-05T10:52:41.560273+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands/server.rb:70:in `start'
2013-05-05T10:52:41.560273+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:254:in `start'
2013-05-05T10:52:41.560273+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands.rb:50:in `<top (required)>'
2013-05-05T10:52:41.560044+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands/server.rb:46:in `app'
2013-05-05T10:52:41.560044+00:00 app[web.1]:    from /app/config.ru:3:in `block in <main>'
2013-05-05T10:52:41.560044+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:in `initialize'
2013-05-05T10:52:41.560044+00:00 app[web.1]:    from /app/config.ru:in `new'
2013-05-05T10:52:41.560044+00:00 app[web.1]:    from /app/config/environment.rb:5:in `<top (required)>'
2013-05-05T10:52:41.560044+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:in `instance_eval'
2013-05-05T10:52:41.560044+00:00 app[web.1]:    from /app/config.ru:in `<main>'
2013-05-05T10:52:41.560273+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:304:in `wrapped_app'
2013-05-05T10:52:41.559812+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/railtie/configurable.rb:30:in `method_missing'
2013-05-05T10:52:41.560044+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:200:in `app'
2013-05-05T10:52:41.559812+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/application.rb:136:in `initialize!'
2013-05-05T10:52:41.560044+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:40:in `eval'
2013-05-05T10:52:41.559812+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/initializable.rb:54:in `run_initializers'
2013-05-05T10:52:41.560044+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:40:in `parse_file'
2013-05-05T10:52:41.560273+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands.rb:55:in `block in <top (required)>'
2013-05-05T10:52:41.560273+00:00 app[web.1]:    from script/rails:6:in `<main>'
2013-05-05T10:52:41.560273+00:00 app[web.1]:    from script/rails:6:in `require'
2013-05-05T10:52:42.686557+00:00 heroku[web.1]: State changed from starting to crashed
2013-05-05T10:52:42.675574+00:00 heroku[web.1]: Process exited with status 1
2013-05-05T10:54:41.605956+00:00 heroku[slugc]: Slug compilation started
2013-05-05T10:55:31.425752+00:00 heroku[api]: Release v11 created by coreypizzle@gmail.com
2013-05-05T10:55:31.456611+00:00 heroku[api]: Deploy b7f5371 by coreypizzle@gmail.com
2013-05-05T10:55:31.596595+00:00 heroku[web.1]: State changed from crashed to starting
2013-05-05T10:55:32.004776+00:00 heroku[slugc]: Slug compilation finished
2013-05-05T10:55:33.337343+00:00 heroku[web.1]: Starting process with command `bundle exec rails server -p 13044`
2013-05-05T10:55:37.791655+00:00 app[web.1]: DEPRECATION WARNING: You have Rails 2.3-style plugins in vendor/plugins! Support for these plugins will be removed in Rails 4.0. Move them out and bundle them in your Gemfile, or fold them in to your app as lib/myplugin/* and config/initializers/myplugin.rb. See the release notes for more on this: http://weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-has-been-released. (called from <top (re
quired)> at /app/config/environment.rb:5)
2013-05-05T10:55:37.792002+00:00 app[web.1]: DEPRECATION WARNING: You have Rails 2.3-style plugins in vendor/plugins! Support for these plugins will be removed in Rails 4.0. Move them out and bundle them in your Gemfile, or fold them in to your app as lib/myplugin/* and config/initializers/myplugin.rb. See the release notes for more on this: http://weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-has-been-released. (called from <top (required)> at /app/config/environment.rb:5)
2013-05-05T10:55:40.844352+00:00 app[web.1]: => Booting WEBrick
2013-05-05T10:55:40.844352+00:00 app[web.1]: => Rails 3.2.12 application starting in production on http://0.0.0.0:13044
2013-05-05T10:55:40.844352+00:00 app[web.1]: => Call with -d to detach
2013-05-05T10:55:40.844352+00:00 app[web.1]: Exiting
2013-05-05T10:55:40.844352+00:00 app[web.1]:    from /app/app/models/follow.rb:1:in `<top (required)>'
2013-05-05T10:55:40.844352+00:00 app[web.1]: => Ctrl-C to shutdown server
2013-05-05T10:55:40.844352+00:00 app[web.1]: /app/app/models/follow.rb:3:in `<class:Follow>': uninitialized constant Follow::ActsAsFollower (NameError)
2013-05-05T10:55:40.844352+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/engine.rb:439:in `block (2 levels) in eager_load!'
2013-05-05T10:55:40.844352+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/engine.rb:438:in `each'
2013-05-05T10:55:40.844352+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/engine.rb:438:in `block in eager_load!'
2013-05-05T10:55:40.844819+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/engine.rb:436:in `each'
2013-05-05T10:55:40.844819+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/engine.rb:436:in `eager_load!'
2013-05-05T10:55:40.844819+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/application/finisher.rb:53:in `block in <module:Finisher>'
2013-05-05T10:55:40.844819+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/initializable.rb:30:in `instance_exec'
2013-05-05T10:55:40.844819+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/initializable.rb:30:in `run'
2013-05-05T10:55:40.844819+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/initializable.rb:55:in `block in run_initializers'
2013-05-05T10:55:40.844819+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/initializable.rb:54:in `each'
2013-05-05T10:55:40.844819+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/initializable.rb:54:in `run_initializers'
2013-05-05T10:55:40.844819+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/application.rb:136:in `initialize!'
2013-05-05T10:55:40.844819+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/railtie/configurable.rb:30:in `method_missing'
2013-05-05T10:55:40.845122+00:00 app[web.1]:    from /app/config/environment.rb:5:in `<top (required)>'
2013-05-05T10:55:40.845122+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:in `initialize'
2013-05-05T10:55:40.845122+00:00 app[web.1]:    from /app/config.ru:in `new'
2013-05-05T10:55:40.845122+00:00 app[web.1]:    from /app/config.ru:in `<main>'
2013-05-05T10:55:40.845122+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands/server.rb:46:in `app'
2013-05-05T10:55:40.845122+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:40:in `eval'
2013-05-05T10:55:40.845122+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:40:in `parse_file'
2013-05-05T10:55:40.845413+00:00 app[web.1]:    from script/rails:6:in `require'
2013-05-05T10:55:40.845413+00:00 app[web.1]:    from script/rails:6:in `<main>'
2013-05-05T10:55:40.845122+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:200:in `app'
2013-05-05T10:55:40.845413+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:304:in `wrapped_app'
2013-05-05T10:55:40.845413+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands.rb:50:in `tap'
2013-05-05T10:55:40.845122+00:00 app[web.1]:    from /app/config.ru:3:in `block in <main>'
2013-05-05T10:55:40.845413+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands.rb:55:in `block in <top (required)>'
2013-05-05T10:55:40.845413+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands/server.rb:70:in `start'
2013-05-05T10:55:40.845413+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/railties-3.2.12/lib/rails/commands.rb:50:in `<top (required)>'
2013-05-05T10:55:40.845413+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/server.rb:254:in `start'
2013-05-05T10:55:40.845122+00:00 app[web.1]:    from /app/vendor/bundle/ruby/1.9.1/gems/rack-1.4.5/lib/rack/builder.rb:51:in `instance_eval'
2013-05-05T10:55:42.225191+00:00 heroku[web.1]: Process exited with status 1
2013-05-05T10:55:42.238768+00:00 heroku[web.1]: State changed from starting to crashed
2013-05-05T10:56:54.541931+00:00 heroku[api]: Scale to web=1 by coreypizzle@gmail.com

preguntado el 05 de mayo de 13 a las 12:05

1 Respuestas

El error es

/app/app/models/follow.rb:3:in `<class:Follow>': uninitialized constant Follow::ActsAsFollower (NameError)

Make sure the plugin you are using is properly loaded and listed in your Gemfile.

contestado el 05 de mayo de 13 a las 12:05

Oh! Thanks, wasn't using that gem, forgot to uninstall it! Thanks anyways! - coreypizzle

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.