No se puede crear un proyecto de aplicación de Android en Eclipse. Mensaje de error: ingrese un nombre de aplicación (que se muestra en el iniciador)

I want to create a fresh Android application project in Eclipse. But when I try to create a project it every time gives me the message on the first screen of creation.

Enter an application name (shown in launcher)

enter image description here

When I remove the theme also

enter image description here

I have already entered a name for that application.

Estoy usando:

  • Android api level 10

  • Eclipse Version: Indigo Service Release 2,Build id: 20120216-1857

  • Operating System : Linux Fedora 17

There are projects which I am developing on the same machine.

I have several times restarted eclipse and my developing machine. What is happening?

This my sdk image for api level 17

enter image description here

Update from the solutions I got that my ADT plugin was not updated for Android sdk tools version 22. So now I have updated it but I have another error. See:

enter image description here

preguntado el 17 de mayo de 13 a las 10:05

@user927258 Reinstalling sdk will be a very heavy task for me. -

try selecting no theme because this theme is not available in froyo -

can you show your sdk manager screen capture -

@Iftikar Urrhman Khan One min -

@Iftikar Urrhman Khan see my updated post. Do you want for api level 10 also. -

4 Respuestas

This issue has been often occurred by Many People. you can see AQUÍ

Solution given by them is to

Update ADT plugin and then SDK tools and after when you will try to create a new project, the error will not occur

Espero que esto ayude.

contestado el 17 de mayo de 13 a las 10:05

Sir this is the exact solution for the problem. Thank you. - Nikhil Agrawal

@Er.NikhilAgrawal : Welcome:) - Bhavesh Patadiya

My ADT and SDK both are updated but still unable to create a new project. Please help..!! - Ritesh

I think you don`t have any API installed to compile. First install an API version in SDK Manager and later try again to create a new project.

ACTUALIZACIÓN:

If you update SDK Android, probably you must update ADT.

For the last error update eclipse.

contestado el 17 de mayo de 13 a las 23:05

ADT is updated? Eclipse is linked correctly with SDK Android? - mrmer

This screen is for SDK, ADT is updated? "Help -> Install new software..." and check the repository aquí - mrmer

previously it was not updated but now after also it is giving new error just updating the screen shot - Nikhil Agrawal

have you seen the new screen shot - Nikhil Agrawal

Add all these to your answers - Nikhil Agrawal

In Eclipse, go to Window -> Android SDK Manager. Select one or more SDK Platforms to install.
You have to install the sdk platforms before creating the Android application project. See if this helps.

contestado el 17 de mayo de 13 a las 10:05

Go to Android SDK Manager

tools -> android sdk buid tools (Select last rev. and install the pack.)

thats worked for me.

Respondido 19 Feb 15, 08:02

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.