¿Cómo instalar Passenger cuando se usa RVM?

Estoy usando RVM y me gustaría instalar Phusion Passenger en Snow Leopard. Después de instalar la gema Passenger (versión 2.2.15), intento ejecutar el script de instalación del módulo Apache passenger-install-apache2-module. Pero compara que no puede encontrar rastrillo:

...
* RubyGems ... encontrado
* Rastrillo ... extraviado
* rack ... encontrado
...

Ya hay un informe de error para esto en el foro de pasajeros, pero además de decirme que espere al Pasajero 3, no parece haber ninguna solución (el enlace simbólico / usr / bin / rake no me funciona)

¿Alguien sabe de alguna manera de solucionar esto solo para instalar el módulo Apache? Una vez instalado, imagino que no importa si el script puede encontrar rake o no.

Solo algunas especificaciones en mi env:

$ cual rubí
/Usuarios/watson/.rvm/rubies/ree-1.8.7-2010.02/bin/ruby

$ ruby ​​-v
ruby 1.8.7 (nivel de parche del 2010 de diciembre de 04 19) [i253-darwin686], MBARI 10.4.0x0, Ruby Enterprise Edition 6770

$ cual rastrillo
/Usuarios/watson/.rvm/gems/ree-1.8.7-2010.02@global/bin/rake

$ rake -V
rake, versión 0.8.7

$ echo $ PATH
/Users/watson/.rvm/gems/ree-1.8.7-2010.02@rails235/bin:/Users/watson/.rvm/gems/ree-1.8.7-2010.02@global/bin:/Users/watson/.rvm/rubies/ree-1.8.7-2010.02/bin:/Users/watson/.rvm/bin:/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11/bin:/opt/local/lib/postgresql84/bin

preguntado el 18 de septiembre de 10 a las 08:09

La versión beta de Passenger 3 está disponible desde la semana pasada, creo, así que no hay que esperar. gem install passenger --pre -

¿Ha intentado seguir el manual? rvm.beginrescueend.com/integration/passenger -

Ejecutar Passenger 3 sería bueno, pero no estoy seguro de que sea una buena idea ejecutarlo todavía en producción. Sí, he seguido el manual, usando rvm ree --passenger. Incluso intenté ejecutar el script con rvm Ruby explícito así: passenger_ruby /Users/watson/.rvm/gems/ree-1.8.7-2010.02@rails235/bin/passenger-install-apache2-module -

Sería útil comprobar el resultado de este comando: "lista de gemas" -

1 Respuestas

Pude superar esto usando "pasajero-instalar-apache2-módulo" en lugar de "sudo pasajero-instalar-apache2-módulo" Aquí hay información de fondo: http://groups.google.com/group/phusion-passenger/browse_thread/thread/a7de8a0a3e4bac21?pli=1

respondido 11 mar '11, 18:03

No es la respuesta que estás buscando? Examinar otras preguntas etiquetadas or haz tu propia pregunta.