Preguntas con respuestas sobre "simbl"

23 preguntas, página #1

0

votos

1

respuestas

vistas 541

SIMBL "[NSCFString objectForKey:]: selector no reconocido enviado a isntance"

Actualmente estoy jugando con SIMBL, intentando hacer mi propio complemento. Actualmente estoy siguiendo el tutorial proporcionado en http://www.culater.net/wiki/moin.cgi/CocoaReverseEngineering y estoy completamente seguro de que lo he seguido exactamente. Sin embargo, cuando compilo y coloco mi paquete en mi SIMBL...

preguntado 10 años, 10 meses

0

votos

1

respuestas

vistas 255

No se pueden enviar notificaciones NSDistributedNotification desde el complemento SIMBL

Estoy desarrollando un complemento SIMBL para TextEdit, el complemento agrega un menú adicional. El menú tiene una serie de elementos que cuando se seleccionan (entre otras cosas) envían mensajes a mi propia aplicación. Para hacer esto, he estado usando NSDistributedNotificationCenter, sin embargo, no puedo enviar notificaciones desde mi ...

preguntado 11 años, 5 meses

4

votos

3

respuestas

vistas 1,475

Inyección de SIMBL / Bundle / dylib en Dock.app

Estoy trabajando en un paquete SIMBL simple para disminuir el tiempo de animación de pantalla completa en Lion. No es gran cosa cambiar la animación de las ventanas, sin embargo, hacerlo para la parte de animación de la barra de menú / escritorio (donde la barra de menú + el escritorio se deslizan a la izquierda) es un problema. ...

preguntado 11 años, 6 meses

4

votos

2

respuestas

vistas 1,230

¿Cuáles son las ventajas y desventajas de SIMBL y mach_star?

Para escribir hacks y extensiones no oficiales para aplicaciones de Mac OS X, parece haber dos opciones en la actualidad: SIMBL y mach_star. Estoy comenzando un proyecto que requerirá inyectar en otro proceso, y necesito decidir entre estas bibliotecas. ...

preguntado 12 años, 0 meses

3

votos

1

respuestas

vistas 505

¿Número de versión de Safari?

Estoy desarrollando un complemento de safari en MAC.Ahora quiero saber todo el número de versión de safari3, safari4, porque puedo ver que en algún complemento de código de muestra info.plist: MinBundleVersion es 5530, y verifico que mi versión de safari es: 3.1.2 (5525.20.1), creo que la versión safari3 de algunos usuarios será más baja ...

preguntado 13 años, 2 meses